
 

 

 

 

 

 

 

Session 1 : Create and apply Style in the
Document

 

A style is a collection of formats that you may use to easily
change the appearance of chosen pages, text, frames, and other
elements in your document. When you apply a style, you’re
applying a whole group of formats at once.

 

 

A document’s uniformity can be improved through the use of
styles. They also make it simple to make large formatting
modifications. For example, you might decide to modify the font
of all headings or the indentation of all paragraphs. The task is
simplified by the use of styles.
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OpenOffice.org supports the following types of styles:

 

a. Page Style – Margin, headers and footers, borders, and
backgrounds are all examples of page styles. Page styles in Calc
also contain the printing sheet sequence.

 

b. Paragraph Style – Text alignment, tab stops, line spacing, and
borders, are controlled by paragraph styles, which can also
include character formatting.

 

c. Character Style – Character styles impact the font and size of
chosen text within a paragraph, as well as bold and italic
formats.

d. Frame Style – Text Wrapping, borders, backgrounds, and
columns are all utilised in frame styles to format image and text
frames.

 

e. Numbering Style or List Style – Numbering style includes a
numbering list and a bullet list in the document.

 

f. Cell Style – Fonts, alignment, borders, background, number

making the textreflow along the boundaries of the frame

&
Ginage text



formats (for example, currency, date, and number), and cell
protection are all examples of cell styles.

 

g. Graphics Style – Line, area, shadowing, transparency,
typeface, connectors, dimensioning, and other attributes are used
in graphic styles in drawings and presentations.

 

 

h. Presentation Style – Font, indents, spacing, alignment, and
tab characteristics are all included in presentation styles.

Using the Styles and Formatting windows

 

The Style and Formatting Windows can be
opened in two different ways.

 

1. In the menu bar, select Format >> Style & Formatting.

 

2. To open the Style and Formatting Windows, press the F11 shortcut
key.

 



 
Style and Formatting Windows also have several additional
options to modify the Style and formatting in document, for
example –

1. Fill Format Mode
2. New Style from Selection
3. Modify Style

1. Update Style 
2. Load Styles

 
 

 

1. Fill Format Mode

 

Fill format mode allows you to quickly apply a style to multiple
places without having to return to the Styles and Formatting
box. When you need to format a large number of scattered
paragraphs, cells, or other items in the same manner, this method
helps a lot.

 



 

 

How to apply Style in Digital Documentation – 

 

1. Select the style you want to use in the Styles and
Formatting window.

 
2. Select Fill Format mode icon in Style and Formatting

Windows.
 

3. Click and drag the mouse pointer to the location in the
document where you wish to apply the style.

 
4. Press Esc when finished.

 
 
2. New Style from Selection

 

You can use the Create New Style option in the Style and
Formatting Windows to create your own style for future usage. 

 

Digital Document provides two different methods to create a
new style in Document. 

• Create new style from Selection
 

• Drag and Drop to create new style 



 
 
 

Create New Style from Selection
 
 
By replicating an existing manual format, you can make a new
style. This new style will only be applied to this document and
will not be saved in the template. 

 

 

For example, you can adjust the formatting of a paragraph or
frame until it looks the way you want it to, and then turn the
formatting of that item into a new style. This technique saves
time because you don’t have to build a new style and memorise
all of the formatting options as discussed earlier.

 
Step 1 : Open the Style and Formatting windows and choose the
type of Style you want to create.

 



Step 2 : Select the item you want to save as a Style in the
document.

 

Step 3 : Select the New Style from the Selection icon in the
Style and Formatting window.

 

Step 4 : In the Create Style dialog, type a name for the new
Style and press Ok button. 

 

 

• Drag and Drop to create New Style
 
 
You can drag and drop a text selection into the Styles and
Formatting window to create a new style.

 

Step 1 : Open the Styles and Formatting window.

 

Step 2 : Select some text and drag it to the Styles and
Formatting window.

 

Step 3 : In the Create Style dialog box, type a name for the new
style. The list shows the names of existing custom styles of the



selected type, if any. Click OK to save the new style.

 

 

Step 4 : If the Paragraph Styles list is showing in the Styles and
Formatting window, a new paragraph style will be added to the
list. If Character Styles are active, the character style will be
added to the list.

 

3. Modify Style

 

Writer has a number of predefined styles, but you can find that
they don’t match your preferences in one way or another. OOo
provides two ways to change both predefined and user-created
custom styles. 

 

• Updating a style from a selection
 

• Load or copy styles from another document or template
 
 
 
 
 
 

•  Updating a Style from a selection 
 



To update a style from a selection:

 

Step 1 : Open the Styles and Formatting window.

 

Step 2 : In the document, select an item that has the format.

 

Step 3 : In the Styles and Formatting window, select the style
you want to update (singleclick, not double-click), then long-
click on the arrow next to the New Style from Selection icon and
click on Update Style

 

• Load or copy styles from another document or
template

 
You can copy styles by loading them from a template or another
document: 

 

Step 1 : Open the document into which you wish to paste styles.



 

Step 2 : Long-click on the arrow next to the New Style from
Selection symbol in the Styles and Formatting window, and then
select Load Styles. 

 

Step 3 : Locate and choose the template you wish to copy styles
from on the Load Styles box.

 

Step 4 : Decide which style categories should be duplicated. If
you want the copied styles to replace any existing styles with the
same names in the document you are pasting them into, choose
Overwrite.

Step 5 : Click OK to copy the styles. You will not see any
change on screen. 

 

 

Session 2 : Insert and use Image

 



There are various ways to insert images into a document,
including via the Drag and Drop, Insert Image from File, Insert
Image from Clipboard, Open Office Gallery, and a scanner.

1. Drag and Drop
2. Insert Image from File
3. Insert Image from Clipboard 
4. Insert Image from Gallery 
5. Insert Image from Scanner

1. Drag and Drop 

 

To drag an image file into a digital document, follow these steps:
–

 

Step 1 : Open a File browser window and locate the image you
want to insert.

 

Step 2 : Drag the image into the Writer document and drop  it
where you want.

 

With this technique, a copy of the picture file is saved inside the
Writer document. Hold down the Control and Shift keys when
you drag the image to link the file rather than embed it.

 

 



 

2. Insert Image from File

 

To insert an image file into a digital document, follow these
steps –

 

Step 1: Click in the Open Office document in the first step to
place the image there.

 

Step 2: From the menu bar, select Insert > Picture > From File.

 

Step 3: Navigate to the file that needs to be inserted on the Insert
Picture dialogue, select it, and click Open.



 
 

3. Insert Image from Clipboard

 

You can copy photos into an OpenOffice document from other
Open Office documents as well as from other programmes by
using the clipboard. How to do it:

• Start by opening the source and destination documents.
 

• Pick the image you want to copy from the source
document.

• To copy the image to the clipboard, move the mouse
pointer over the chosen image and hit Control+C.

 
• Change to the desired document.

 
• Click to position the cursor in the desired location for

the graphic.
 

• To insert the image, press Control+V.
 

 

4. Insert Image from Gallery 

 

 

 

The Gallery provides a suitable way to organise reusable



elements that you may add to your papers, like images and
music. All parts of Open Office have access to the Gallery.
There aren’t many visuals included, but you can upload your
own or locate addons with extra graphics.

 
 
 

5. Insert Image from Scanner

If your computer has a scanner attached, Open Office may
access the scanning software and enter the scanned item as an
image into the Open Office document. To insert image 

Click the area where the image to be placed, then choose Insert
> Picture > Scan > Select Source to begin the process.

 



Modifying An Image 

You might need to edit a new image you include so that it
matches the document. Here, we’ll go through how to use the
Picture toolbar, as well as how to resize, crop, and rotate a photo
using a workaround.

1. Picture Toolbar 

The Picture toolbar displays when you insert a picture or choose
one that is already in the page. View > Toolbars > Picture allows
you to set it to always be visible.

2. Graphics mode

You can change color images to grayscale by selecting the
image and then selecting Grayscale from the Graphics mode list.

3. Flip vertically or horizontally

Select the image, then click the corresponding icon to turn it
vertically or horizontally.

4. Filters

The filters are briefly described in the following table, but the
best way to comprehend them is to use them. Try around with
the various filters and their settings. 



 

 

5. Transparency

To make a picture more transparent, change the percentage value
in the Transparency box on the Picture toolbar. When making a
watermark or enclosing the image in the background.

6. Using The Formatting Toolbar And Picture Dialog 

a. Cropping Images 

You could want to crop (cut off) a portion of the image if you’re



only interested in it for your document. Right-click the image
and choose Picture from the pop-up menu to begin cropping it.

b. Keep scale / Keep image size

When the Keep scale option is used (the default), cropping an
image does not alter its scale.

When the option to Keep Picture Size is used, cropping results
in either an increase in image size (for positive cropping values),
a decrease in image size (for negative cropping values), or an
image distortion.

c. Width and Height 

As you input values in the Left, Right, Top, and Bottom fields
under Scale or Image size, the Width and Height fields change.
To find the precise amount to crop by, use the thumbnail next to
these fields.

d. Resizing an Image 

If the inserted image is too big or too small, it might not fit into



the paper completely.  You can resize the image in Writer.

e. Rotating a Picture 

With the aid of the rotation option in digital documentation, you
can rotate the image.

f. Creating Drawing Objects 

Display the Drawing toolbar by selecting View > Toolbars >
Drawing to start utilising the drawing tools.

Session 3 : Create and use Template

A template is a sample that you can follow while writing new
documents. Documents that have previously been designed are
called templates. Simply substitute your own text for the sample
text.

Creating a Template 

You can create your own templates in two ways: 

• from a document, 
• and using a wizard. 
• Creating A Template From A Document

Step 1 : Open a new or existing document of the type you want
to make into a template (text document, spreadsheet, drawing,
presentation).

Step 2 : Add the content and styles that you want.

Step 3 : From the main menu, choose

File > Templates > Save.
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• Creating A Template Using A Wizard 
Step 1 :  Choose File > Wizards >[type of template required]

Step 2 : Follow the instructions on the pages of the wizard like
the date, subject line , salutation, and complimentary close

Step 3 : In the last section of the wizard, you can specify the
name and location for saving the template.

Step 4 : Finally, you have the option of creating a new document
from your template immediately, or manually changing the
template.

Session 4 : Create and customize Table of
Contents isthe

indexof any documentoran



A table of contents (TOC) is a reader navigation tool used in a
variety of writing formats, including books and technical
documentation. It comprises a list of the major chapters,
headings, subjects, sections, and so on.

The table of contents serves two things – 

1. It provides users with a summary of the contents and
structure of the document. 

2. It enables users to jump right to a certain area of an
online document.

How to Insert Table of Content in Digital Documentation 

To insert table of Content in Digital Document follow the
following link – 

Insert > Indexes and Tables > Indexes and Tables.

Basic Setting in Table of Content 

1. Adding A Title



Put a title in the Title area if you want one for the table of
contents. (If Writer automatically entered a title in this field, you
may edit it by typing over the value.) Clear the Title field to
remove the title.

Digital Documentation Class 10 Notes

2. Protecting Against Manual Changes

Select the Protected against manual changes checkbox to
prevent accidental changes to the table of contents.

If this box is checked, the context menu or the Insert
Table/Index window are the only ways to modify the table of
contents.

If this box is unchecked, The table of contents can be modified
immediately on the document page, just like regular text..

3. Changing The Number Of Levels

When creating the table of contents, Writer by default considers
10 levels of headings.

Enter the required number in the “Evaluate up to level” spin box
to adjust the number of levels examined.

4. Assigning Custom Styles

All paragraphs created using the default heading styles are
automatically assigned to the table of contents by Writer
(Heading 1, Heading 2, and so on).

5. Using The Entries Tab

Entries in the table of content can add and remove elements, like

->>>



chapter numbers, and you can apply character styles to specific
sections. Entries in the table of contents serve to highlight the
content.

E# – The chapter number is indicated by the E# button.

E – The entered text is represented by the E button.

T – A tab stop is represented by the T button.

# – The page number is indicated by the # button.

LS – The beginning of a hyperlink is indicated by the LS button.
(This button is absent from the Structure line by default.)

LE – A hyperlink’s conclusion is indicated by the LE button.



(This button is absent from the Structure line by default.)

6. Deleting Elements

Click the button next to the element you want to remove from
the Structure line, and then press the Delete key on your
computer. For instance, click the T button and then press the
Delete key to remove a tab stop.

7. Using The Background Tab

To add colour or a graphic to the table backdrop, use the
Background tab.

8. Saving The Table Of Contents

Click OK to save the table of contents and have it display in
your document. The table of contents is displayed in your
document once the Insert Index/Table window closes.

Session 5 : Implement Mail Merge

Using a mail merge, you can personalise a letter you’ve already
written and send it to a large group of recipients, giving the
impression that you wrote it specifically for them. A mail merge
can also be a rapid technique to create labels or envelopes with
the addresses for various persons on each label or envelope
using a list of people’s mailing addresses. 

Anyone or any business that interacts frequently with customers,
partners, parents, or other individuals must use the mail merge.

How to create Mail Merge in Digital Documentation 

Step 1: Select starting document



Step 2: Select document type

Step 3: Insert address block or Selecting the data source

Step 4: Create salutation

Step 5: Adjust layout

Step 6: Edit document and insert extra fields

Step 7: Personalize documents

Step 8: Save, print or send 

What is Data Source

During the mail merge process, data from another document
referred to as the data source, Data Source connects to the main
document and retrieves the information like names, addresses,
and phone numbers can be found in a document, spreadsheet, or
database that serves as the data source.

What are the different type of Data Source available in
Mail Merge

OpenOffice.org allows data sources to be accessed and then
linked into OOo documents. For example, a mail merge links an
external document containing a list of names and addresses into
a letter, with one copy of the letter being generated for each
entry.

Different type of File which support to insert data in Mail merge
are – 

1. Spreadsheet



2. Text File
3. Access or Base Database 
4. Address Book

 


