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KALPAVRUKSHA MODEL SCHOOL, BAILHONAGL 

Class: IX          Sub: IT 

UNIT 4: ELECTRONIC SPREADSHEET 

1. CREATE A SPREADSHEET 

1.1 Introduction to spreadsheet:  
Spreadsheet: A spreadsheet or worksheet is a file made 

of rows and columns that helps to sort, organize, and arrange data efficiently, and 

calculate numerical data. 

Electronic Spreadsheet: An electronic spreadsheet can be used to automatically 

perform numerical calculations. 

Examples of spreadsheet programs: 

 Google Sheets - (online and free). 

 iWork Numbers - Apple Office Suite. 

 LibreOffice -> Calc (free). 

 Microsoft Excel. 

 OpenOffice -> Calc (free). 
 

Uses for spreadsheet software: 

 Household Finance Planning  

 Business Accounts and Budgeting  

 Invoices  

 Wages  

 Calculations e.g. Adding, Subtracting, etc.  

 Creating Graphs e.g. bar chart, pie chart. 

 Collect data from different sources e.g. phone number, prices.  
 

Advantages of Spreadsheet:  

 Calculations are correct.  

 Calculations are completed automatically.   

https://www.computerhope.com/jargon/r/row.htm
https://www.computerhope.com/jargon/c/column.htm
https://www.computerhope.com/jargon/n/numeric.htm
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 Information is organised and easy to access.  

 Information is easy to edit if a mistake has been made by retyping or using 

‘undo’. 

 Data can be easily sorted and filtered. 

 Data can be quickly analysed. 

 Reports can be made more visual by using charts and graphs. 

 

1.2 Starting a Spreadsheet: 

     Steps to start MS-Excel are:- 

1. Double Click on a shortcut key of the MS-Excel icon, if available, on the 
desktop. 

                                                 OR 

2. Click Start - > All Programs->Microsoft Office->MS Excel 
 

 1.3 Components of a Spreadsheet: 

 Following are the components of a spreadsheet are:- 

1. Worksheet: It is grid of horizontal rows and vertical columns. 

2. Workbook: A workbook contains one or more worksheets. 

3. Row: A row is horizontal arrangement of cells.  

 The rows are named by numbers (1, 2, 3, 4…). 

 There are 1,048,576 rows on a worksheet. 

  Row height is 409 points. 

4. Column: A column is a vertical arrangement of cells.  

  The columns are named by alphabets (A, B, C….Y, Z, AA, AB, AC… AZ, BA, BB…) 

  There are 16,384 columns on a worksheet. 

  Column width is 255 characters. 

5. Cell: A cell is where the rows and columns intersect. Worksheet is also called 

an array of cells.  

  A cell may contain text, numbers, date or a formula. 

 A cell address in a spreadsheet identifies location of the cell. 
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  It is a combination of column name and row number of the cell, such as A2 or 

B16 etc. 

6. Active cell: This is the cell on which the cursor is currently placed. It is outlined 

by a dark border. Data is always entered in the active cell. 

7. Formula Bar: This is located below the Ribbon. It displays the contents of the 

active cell. It can also be used to enter and edit data. 

8. Scroll Bar: These helps to scroll through the content and body of the 

worksheet. There are two scroll bars –  

                     a. Horizontal scroll bar 

 b. Vertical scroll bar 

9. Cell Range: A cell range in an Excel file is a collection of selected cells. 
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2. APPLY FORMULA AND FUNCTIONS IN SPREADSHEET 

2.1 Different types of data: 

There are three types of data in cells: labels, values, and formulas. 

a) Label (text): Labels are descriptive pieces of information, such as names, 

months, or other identifying statistics, and they usually include alphabetic 

characters. 

b) Values (numbers): Values are generally raw numbers or dates. 

c) Formula: Formulas are instructions for Excel to perform calculations. 

2.2 Entering Data: 

1. To enter data in Excel, just select a cell and begin typing. You'll see the text 
appear both in the cell and in the formula bar above. 

2. To tell Excel to accept the data you've typed, press enter. The information will 
be entered immediately, and the cursor will move down one cell. 

3. You can also press the tab key instead of the enter key. If you press tab, the 
cursor will move one cell to the right once the information has been entered. 

4. When Excel sees that you are typing into a list, pressing enter at the end of 
the row will move the cursor down one row and back to the first column. 

5. At any time while you are typing you can press the escape key to cancel. This 
brings Excel back to the state it was in before you started typing. 

6. When you want to delete information that has already been entered, just 
select the cells, and press the delete key. 

 

2.3 Mathematical Operators used in formula: 

1. Excel uses standard operators for equations, such as a  
2. plus sign for addition (+),  
3. minus sign for subtraction (-),  
4. asterisk for multiplication (*), 
5. forward slash for division (/), and  
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6. caret (^) for exponents. 

Note: All formulas must begin with an equals sign (=).  

 

  

2.4 

Entering Formula: 

To enter a formula, execute the following steps. 

1. Select a cell. 

2. To let Excel know that you want to enter a formula, type an equal sign (=). 

3. Type the formula for example, A1+A2. 

4. Press Enter key 

 
 
Edit a Formula 
When you select a cell, Excel shows the value or formula of the cell in the formula 
bar. 

1. To edit a formula, click in the formula bar and change the formula. 

2. Press Enter key. 

2.5 Entering Function: 

Function: A function is a predefined formula that performs calculations using specific values 

in a particular order.  
 

Insert a Function in Excel: 
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1. Click the cell where you want to add a formula. 
2. Click the Insert Function button. 

3. Search for a function using one of these methods: Type a few keywords that describe the 
function you want and click Go. ... 

4. Select the desired function. 

5. Click OK. ... 

6. Enter the formula arguments. 

7. Click OK. 

The parts of a function: 
Syntax: In order to work correctly, a function must be written a specific way, which is called 

the syntax.  

 The basic syntax for a function is the equals sign (=), the function name (SUM, for 

example), and one or more arguments.  
 
 

             Syntax  

There are three parts in syntax: 
1. Equal sign (=) 
2. Function name 
3. Argument 

 
 Excel includes many common functions that can be used to quickly find 

the sum, average, count, maximum value, and minimum value for a range of cells. In 
order to use functions correctly, you'll need to understand the different parts of a 
function and how to create arguments to calculate values and cell references. 

 Once you are familiar with the function you want to use, all you have to do is enter an 
equal sign (=) in the cell, followed by the name of the function and the cell range it 
applies to.  

 
 
Creating a function: 
There are a variety of functions available in Excel. Here are some of the most common 

functions you'll use: 
 SUM: This function adds all of the values of the cells in the argument. 

 AVERAGE: This function determines the average of the values included in the 
argument. It calculates the sum of the cells and then divides that value by the 
number of cells in the argument. 
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 COUNT: This function counts the number of cells with numerical data in the 
argument. This function is useful for quickly counting items in a cell range. 

 MAX: This function determines the highest cell value included in the argument. 

 MIN: This function determines the lowest cell value included in the argument. 

Creating function using the AutoSum command: 
The AutoSum command allows you to automatically insert the most common functions into 

your formula, including SUM, AVERAGE, COUNT, MIN, and MAX.  

 AutoSum command is available under Home tab in Editing Group. 

 

 
 

Steps to insert a function using AutoSum Command: 
1) Select the cell that will contain the function. 

2) In the Editing group on the Home tab, click the arrow next to the AutoSum command. 

Next, choose the desired function from the drop-down menu. 

3) Excel will place the function in the cell and automatically select a cell range for the 

argument. 

4) Press Enter on your keyboard. The function will be calculated, and the result will appear 

in the cell. 

Note: The AutoSum command can also be accessed from the Formulas tab on the Ribbon. 

Insert a column:  

Following are the steps to insert a column. 
1) Select a column where you want to insert a column. 
2) Click mouse right button, it display a menu and select insert option.  
3) A column will be inserted. 
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Insert a Row:  

Following are the steps to insert a row. 
1) Select a column where you want to insert a row. 
2) Click mouse right button, it display the menu and select insert option.  
3) A row will be inserted. 

 

Delete a column:  

Following are the steps to delete a column. 
1) Select a column which you want to delete. 
2) Click mouse right button, it display the menu and select delete option.  
3) Selected column will be deleted. 

 

Delete a row:  

Following are the steps to delete a row. 
1) Select a row which you want to delete. 
2) Click mouse right button, it display the menu and select delete option.  
3) Selected row will be deleted. 

 

Rename a Sheet in a spreadsheet: 
Following are the steps to insert a sheet in a spreadsheet. 

1) Select the sheet which you want to rename. 
2) Click mouse right button, it display the menu and select rename option.  
3) Selected sheet will be renamed. 

 

Delete a Sheet in a spreadsheet: 
Following are the steps to delete a sheet in a spreadsheet. 

1) Select the sheet which you want to delete. 
2) Click mouse right button, it display the menu and select delete option.  
3) Selected sheet will be deleted. 

 

3. FORMAT DATA IN THE SPREADSHEET: 

3.1 Formatting tool: 
 All cell content uses the same formatting by default, which can make it difficult to 

read a workbook with a lot of information.  
 Basic formatting can customize the look and feel of your workbook, allowing you to 

draw attention to specific sections and making your content easier to view and 
understand. 
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To change the font: 
 By default, the font of each new workbook is set to Calibri.  
 When creating a workbook in the workplace, you have to select a font that is easy to 

read.  
 Along with Calibri, standard reading fonts include Cambria, Times New Roman, and 

Arial. 

To change the font size: 

1. Select the cell(s) you want to modify. 

2. Click the drop-down arrow next to the Font Size command on the Home tab. 
The Font Size drop-down menu will appear. 

3. Select the desired font size. A live preview of the new font size will appear as 
you hover the mouse over different options. In our example, we will 
choose 16 to make the text larger. 

4. The text will change to the selected font size. 

To change the font color: 

1. Select the cell(s) you want to modify. 

2. Click the drop-down arrow next to the Font Color command on the Home tab. 
The Color menu will appear. 

3. Select the desired font color. A live preview of the new font color will appear as you 
hover the mouse over different options. In our example, we'll choose Green. 

4. The text will change to the selected font color. 

Note: Select More Colors at the bottom of the menu to access additional color options. 
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To use the Bold, Italic, and Underline commands: 

1. Select the cell(s) you want to modify. 

2. Click the Bold (B), Italic (I), or Underline (U) command on the Home tab. In our 
example, we'll make the selected cells bold. 

3. The selected style will be applied to the text. 

Cell borders and fill colors 

Cell borders and fill colors allow you to create clear and defined boundaries for different 
sections of your worksheet. Below, we'll add cell borders and fill color to our header cells to 
help distinguish them from the rest of the worksheet. 

To add a border: 

1. Select the cell(s) you want to modify. 

2. Click the drop-down arrow next to the Borders command on the Home tab. 
The Borders drop-down menu will appear. 

3. Select the border style you want to use. In our example, we will choose to 
display All Borders. 
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4. The selected border style will appear. 

You can draw borders and change the line style and color of borders with the Draw 
Borders tools at the bottom of the Borders drop-down menu. 

 

To add a fill color: 

1. Select the cell(s) you want to modify. 

2. Click the drop-down arrow next to the Fill Color command on the Home tab. 
The Fill Color menu will appear. 

3. Select the fill color you want to use. A live preview of the new fill color will 
appear as you hover the mouse over different options. In our example, we'll 
choose Light Green. 
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4. The selected fill color will appear in the selected cells. 

Format Painter 

If you want to copy formatting from one cell to another, you can use the Format 
Painter command on the Home tab. When you click the Format Painter, it will copy all of 
the formatting from the selected cell. You can then click and drag over any cells you want to 
paste the formatting to. 

 

Text alignment 

 By default, any text entered into your worksheet will be aligned to the bottom-left of 
a cell. 

 By default, any numbers entered will be aligned to the bottom-right.  
 Changing the alignment of your cell content allows you to choose how the content is 

displayed in any cell, which can make your cell content easier to read. 

Following are the two different types of text alignment options: 

1) Horizontal text alignment: 
a) Left align: Aligns content to the left border of the cell 
b) Centre align: Aligns content an equal distance from the left and right 

borders of the cell 
c) Right Align: Aligns content to the right border of the cell 

 

2) Vertical text alignment: 
a) Top Align: Aligns content to the top border of the cell 
b) Middle Align: Aligns content an equal distance from the top and 

bottom borders of the cell. 
c) Bottom Align: Aligns content to the bottom border of the cell 

To change horizontal text alignment: 

1. Select the cell(s) you want to modify. 
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2. Select one of the three horizontal alignment commands on the Home tab. In 
our example, we'll choose Centre Align. 

3. The text will realign. 

To change vertical text alignment: 

1. Select the cell(s) you want to modify. 

2. Select one of the three vertical alignment commands on the Home tab. In our 
example, we'll choose Middle Align. 

3. The text will realign. 

Note: You can apply both vertical and horizontal alignment settings to any cell. 

Change the orientation of text in a cell: 

1. Select a cell, row, column, or a range. 
2. Select Home > Orientation, and then select an option. 

You can rotate your text up, down, clockwise, or counter clockwise, or align text 
vertically: 

Rotate text to a precise angle: 

1. Select a cell, row, column, or a range. 
2. Select Home > Orientation > Format Cell Alignment. 
3. Under Orientation on the right side, in the Degrees box, use the up or down arrow 

to set the exact number of degrees that you want to rotate the selected cell text. 

Wrap text in a cell:  
Microsoft Excel can wrap text so it appears on multiple lines in a cell. You can format the 

cell so the text wraps automatically, or enter a manual line break. 

 

Wrap text automatically 

1. In a worksheet, select the cells that you want to format. 
2. On the Home tab, in the Alignment group, click Wrap Text. (On Excel for desktop, 

you can also select the cell, and then press Alt + H + W.) 
Notes:  

 Data in the cell wraps to fit the column width, so if you change the column width, 
data wrapping adjusts automatically. 
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 If all wrapped text is not visible, it may be because the row is set to a specific height 
or that the text is in a range of cells that has been merged. 

Adjust the row height to make all wrapped text visible 

1. Select the cell or range for which you want to adjust the row height. 
2. On the Home tab, in the Cells group, click Format. 
3. Under Cell Size, do one of the following: 
 To automatically adjust the row height, click AutoFit Row Height. 
 To specify a row height, click Row Height, and then type the row height that you 

want in the Row height box. 

Tip: You can also drag the bottom border of the row to the height that shows all 
wrapped text. 

Merge Cells in Excel 
Merged cell: Combines two or more cells in Excel to create a new, larger cell is called 

merged cell. 

 This is useful for organizing information and creating headers, without the need to 

resize individual cells. Here's how to do it. 

Merge Cells with the Merge & Center Command in the Home Tab 
1. Select the cells you want to merge together. 

2. Go to the Home tab. 

3. Click on the Merge & Center command found in the Alignment section. 
 

Fill Handle: 

 There may be times when you need to copy the content of one cell to several 
other cells in your worksheet.  

 You could copy and paste the content into each cell, but this method would be 
time consuming.  

 Instead, you can use the fill handle to quickly copy and paste content 
to adjacent cells in the same row or column. 

Steps to use fill handle: 

1. Select the cell(s) containing the content you want to use. The fill handle will 
appear as a small square in the bottom-right corner of the selected cell(s). 



15 
 

 

2. Click, hold, and drag the fill handle until all of the cells you want to fill 
are selected. 

 

3. Release the mouse to fill the selected cells. 
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To continue a series with the fill handle: 

 The fill handle can also be used to continue a series. Whenever the content of a 
row or column follows a sequential order, like numbers (1, 2, 3) or days (Monday, 
Tuesday, Wednesday), the fill handle can guess what should come next in the 
series.  

 In many cases, you may need to select multiple cells before using the fill handle to 
help Excel determine the series order.  

 In our example below, the fill handle is used to extend a series of dates in a 
column. 

 

 

You can also double-click the fill handle instead of clicking and dragging. This can be 
useful with larger spreadsheets, where clicking and dragging may be awkward. 
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4. UNDERSTAND AND APPLY REFERENCING 

4.1 Concept of cell referencing in a spreadsheet: 

Cell Reference: Cell reference in excel is the like referring to other cells to a cell to 

use its values or its properties to other cell. 

 In simple terms if we have data in some random cell A2 and we want to use that 

value of cell A2 in cell A1 we can simply use =A2 in cell A1 and this will copy the 

value of A2 in A1, this is called as cell referencing in excel. 

 

 

Types of Cell Reference in Excel 

1. Relative cell references: 

 It does not contain dollar signs in a row or column, e.g., A2. Relative cell reference type 
in excel changes when a formula is copied or dragged to another cell; in Excel, cell 
referencing is relative by default; it is the most commonly used cell reference in the 
formula. 

2. Absolute cell references:  

Absolute Cell Reference contains dollar signs attached to each letter or number in a 
reference, e.g., $B$4, Here if we mention a dollar sign before the column and row 
identifiers, it makes absolute or locks both the column and the row, i.e., where Cell 
reference remains constant even if it copied or dragged to another cell. 

3. Mixed cell references in Excel:  

It contains dollar signs attached to either the letter or the number in a reference. E.g., 
$B2 or B$4. It is a combination of relative and absolute references. 

https://www.wallstreetmojo.com/relative-references-in-excel/
https://www.wallstreetmojo.com/relative-references-in-excel/
https://www.wallstreetmojo.com/absolute-reference-in-excel/
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5. WORKING WITH CHARTS: 

Charts: A chart is a visual representation of numeric values.  

 Charts allow you to illustrate your workbook data graphically, which makes it easy to 
visualize comparisons 

Types of Charts: All types of charts are available in Chart group under Insert tab.  

Column:  column chart is a bar-shaped chart that has a bar placed on the X-axis. This 
type of chart in excel is called a column chart because the bars are placed on the 
columns. 
 Such charts are very useful in case we want to make a comparison. 
 

Bar: In the Bar chart, the data is plotted on the Y-axis. This is why this is called a 

bar chart. As compared to the column chart, these charts use the Y-axis as the 

primary axis. 

 This chart is plotted on rows that are why this is called a row chart. 

 

Pie: A pie chart is a circle-shaped chart that is capable of representing only one 

series of data. A pie chart has various variants that are a 3d chart and doughnut 

charts. 
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 This is a circle-shaped chart that divides itself into various portions to show 

the quantitative value. 

 

Line: Line charts are used in case we need to show the Trend in data. They are 

more likely used in analysis rather than showing data visually. 

 In this type of chart, a line represents the data movement from one point to 

another. 

 

Area: Area chart and the line charts are logically the same, but the difference that makes 
a line chart an Area chart is that the space between the Axis and the plotted value is 
coloured and is not blank. An area chart emphasizes the magnitude of change over time. 
 

X Y Scatter: An xy (scatter) chart shows the relationships among the numeric values in 
several data series, or plots two groups of numbers as one series of xy coordinates. 

 

Stock: This chart type is most often used for stock price data, but can also be used for 
scientific data (for example, to indicate temperature changes). 
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Surface: A surface chart is useful when you want to find the optimum combinations 
between two sets of data. As in a topographic map, colours and patterns indicate areas 
that are in the same range of values. 

 

Doughnut: Like a pie chart, a doughnut chart shows the relationship of parts to a whole; 
however, it can contain more than one data series. 
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Bubble: Data that is arranged in columns on a worksheet, so that x values are listed in 
the first column and corresponding y values and bubble 

Parts/elements of a Chart: Following are the parts/elements of a chart. 

a) Chart area 
b) Chart title 
c) Data series  
d) Grid line 
e) Vertical axis title 
f) Horizontal axis title 
g) Legends 
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Steps to create a chart: 

1. Select the cells you want to chart, including the column titles and row labels. 
These cells will be the source data for the chart. 

 

2. Click the Insert tab.  

3. In the Charts group, select the desired chart 

category  

4. Select the desired chart type from the drop-down menu. 

 

5. The chart will appear in the worksheet. 

 

 


