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CBSE CLASS 10 IT CODE 402 

{ New Syllabus 2020-21 (Revised) For Theory } 

 

UNIT 1:  DIGITAL DOCUMENTATION 

(ADVANCED) 

  

Important Notes to score 50/50 in theory 

 

 

 

SESSION 1: CREATE AND APPLY STYLES IN THE DOCUMENT   

A style is a set of formats that you can apply to selected pages, text, frames, 
and other elements in your document to quickly change their appearance. 
When you apply a style, you apply a whole group of formats at the same 
time. 

For example, you may decide to change the indentation of all paragraphs, or 
change the font of all titles. 
 

OpenOffice.org supports the following types of styles: 

• Page styles include margins, headers and footers, borders and 
backgrounds. In Calc, page styles also include the sequence for printing 
sheets. 

http://www.crackmycbse.com/


For video lectures Youtube – Platinum Classes     Website : www.crackmycbse.com 

 

 

• Paragraph styles control all aspects of a paragraph’s appearance, such 
as text alignment, tab stops, line spacing, and borders, and can include 
character formatting. 

• Character styles affect selected text within a paragraph, such as the 
font and size of text, or bold and italic formats. 

• Frame styles are used to format graphic and text frames, including 
wrapping type, borders, backgrounds, and columns. 

• Numbering styles apply similar alignment, numbering or bullet 
characters, and fonts to numbered or bulleted lists. 

• Cell styles include fonts, alignment, borders, background, number 
formats (for example, currency, date, number), and cell protection. 

• Graphics styles in drawings and presentations include line, area, 
shadowing, transparency, font, connectors, dimensioning, and other 
attributes. 

• Presentation styles include attributes for font, indents, spacing, 
alignment, and tabs. 

 

Applying styles 

OpenOffice.org provides several ways for you to select styles to apply. 

 

Creating a new style from a selection 

 
You can create a new style by copying an existing manual format. 

• Open the Styles and Formatting window and choose the type of style 
you want to create. 
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• In the document, select the item you want to save as a style. 
• In the Styles and Formatting window, click on the  
 

New Style from Selection 

• In the Create Style dialog, type a name for the new style. The list 
shows the names of existing custom styles of the selected type. Click 
OK to save the new style. 

 

 

 

Modifying styles 

OpenOffice.org provides several ways to modify styles (both the predefined 
styles and custom styles that you create): 

• Updating a style from a selection 
• Load or copy styles from another document or template 
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SESSION 2 : INSERT AND USE IMAGES 

Images can be added to a document in several ways: by inserting an image 
file, directly from a graphics program or a scanner, or from the OOo Gallery. 

 

Inserting an image file 
When the image is in a file stored on the computer, you can insert it into an 
OOo document using either of the following methods: 

➢ Drag and drop 
• Open a file browser window and locate the image you want to insert. 
• Drag the image into the Writer document and drop it where you want it 

to appear. A faint vertical line marks where the image will be dropped. 

➢ Insert Picture dialog 
• Click in the Open Office document where you want the image to 

appear. 
• Choose Insert > Picture > From File from the menu bar. 
• On the Insert Picture dialog (see Figure 5), navigate to the file to be 

inserted, select it, and click Open. 

 
At the bottom of the dialog are two options, Preview and Link. Select 
Preview to view a thumbnail of the selected image on the right, so you can 
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verify that you have the correct file. See below for the use of Link. 
 

Inserting An Image From The Clipboard 
 
1. Open both the source document and the target document. 

2. In the source document, select the image to be copied. 

3. Move the mouse pointer over the selected image and press Control+C to 

copy the image to the clipboard. 

4. Switch to the target document. 

5. Click to place the cursor where the graphic is to be inserted. 

6. Press Control+V to insert the image. 

 
 

Inserting An Image Using A Scanner 

To start this procedure, click where you want the graphic to be inserted and 

select Insert > Picture > Scan > Select Source. 

 

Inserting An Image From The Gallery 

1. To open the Gallery, click on the Gallery icon (located in the right side of 

the Standard toolbar) or choose Tools > Gallery from the menu bar. 

2. Navigate through the Gallery to find the desired picture. 
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3. To insert the picture, click and drag it from the Gallery into the Writer 

document. You can also right-click on the picture and choose Insert>Copy. 

 

Modifying an image 
When you insert a new image, you may need to modify it to suit the 
document. Here we will discuss the use of the Picture toolbar, resizing, 
cropping, and a workaround to rotate a picture. 

➢ Using the Picture toolbar 

When you insert an image or select one already present in the document, 
the Picture toolbar appears. You can set it to always be present (View > 
Toolbars > Picture). Picture control buttons from the Picture toolbar can 
also be added to the Standard Toolbar.  

From these three toolbars, you can apply small corrections to the graphic 
or obtain special effects. 

Graphics mode  
You can change color images to grayscale by selecting the image and then 
selecting Grayscale from the Graphics mode list. 

Flip vertically or horizontally  
To flip an image vertically or horizontally, select the image, and then click 
the relevant icon. 

Filters 
Table 1 provides a short description of the available filters, however the 
best way to understand them is to see them in action. Feel free to 
experiment with the different filters and filters settings, remembering that 

http://www.crackmycbse.com/


For video lectures Youtube – Platinum Classes     Website : www.crackmycbse.com 

 

 

you can undo all the changes by pressing Ctrl+Z or Alt+Backspace or by 
selecting Edit > Undo. 

Color 
Use this toolbar to modify the individual RGB color components of the 
image (red, green, blue) as well as the brightness, contrast, and gamma of 
the image. If the result is not satisfactory, you can press Control+Z to 
restore the default values. 

 

Table 1: Graphic filters and their effects 
Icon Name Effect 

 Invert 
Inverts the color values of a color image or the 
brightness values of a grayscale image. 

 Smooth Softens the contrast of an image. 

 Sharpen Increases the contrast of an image. 

 
Remove 
noise Removes single pixels from an image. 

 Solarization 
Mimics the effects of too much light in a picture. 
A further dialog box opens to adjust the 
parameters. 

 Aging 
Simulates the effects of time on a picture. Can be 
applied several times. A further dialog box opens 
to adjust the aging level. 

 Posterize Makes a picture appear like a painting by 
reducing the number of colors used. 

 Pop Art Modifies the picture dramatically. 
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Icon Name Effect 

 Charcoal Displays the image as a charcoal sketch. 

 Relief 
A dialog box is displayed to adjust the light 
source that will create the shadow and, hence, the 
relief effect. 

 Mosaic Joins groups of pixels into a single area of one 
color. 

 

Transparency  
Modify the percentage value in the Transparency  box on the Picture toolbar 
to make the image more transparent. This is particularly useful when creating 
a watermark or when wrapping the image in the background. 

 
 
Using The Formatting Toolbar And Picture Dialog 

Grouping Drawing Objects 

1. Select one object, then hold down the Shift key and select the others you 

want to include in the group. The bounding box expands to include all the 

selected objects. 

2. With the objects selected, hover the mouse pointer over one of the objects 

and choose Format > Group > Group from the menu bar or right-click and 

choose Group > Group from the pop-up menu. 
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Positioning image/graphics within the text 

When you add a graphic to a text document, you need to choose how to 
position it with respect to the text and other graphics.  

Positioning of a graphic is controlled by four settings: 
1. Arrangement refers to the placement of a graphic on an imaginary 

vertical axis. Arrangement controls how graphics are stacked upon each 
other or relative to the text. 

2. Alignment refers to the vertical or horizontal placement of a graphic in 
relation to the chosen anchor point. 

3. Anchoring refers to the reference point for the graphics. This point could 
be the page, or frame where the object is, a paragraph, or even a 
character. An image always has an anchor point. 

4. Text wrapping refers to the relation of graphics to the surrounding text, 
which may wrap around the graphic on one or both sides, be overprinted 
behind or in front of the graphic, or treat the graphic as a separate 
paragraph or character. 

 

3. CREATE AND USE TEMPLATE 

A template is a model that you use to create other documents. For example, 
you can create a template for business reports that has your company’s logo 
on the first page. New documents created from this template will all have 
your company’s logo on the first page. 
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Using The Template  
To use a particular template, choose File > New > Templates and 
Documents. 
  

Changing To A Different Template  
To change to a different template, choose File > New > Templates and 
Documents. 
 

Working with tables  

A table is a grid, an arrangement of rectangles, or cells, in rows and column. 

You can use tables to format all or part of your document into columns and 

rows. You need tables because they are the best way to organize graphics, 

columns, headings and rows. 

 

Column- A column is a grouping of cells that run from the top to the bottom 

of a page. 

Rows- Row is a grouping of cells that run from the left to right of a page. 

Cell- The intersection point between a row and a column is a cell. 

 

Inserting a Table 

1. Position the insertion point where you want the table to appear. 

2. Choose Table ->Insert ->Table option. This will display the Insert Table   
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dialog box. 

 
 

3. Enter the number of rows and columns for the table in the number of 

columns  

and the number of row boxes. 

 

 

 4.   CREATE AND CUSTOMIZE TABLE OF CONTENTS  

Writer's table of contents feature lets you build an automated table of 

contents from the headings in your document.. For example, you can use the 

Heading 1 style for chapter titles and the Heading 2 and Heading 3 styles 

for chapter subheadings. 

 

http://www.crackmycbse.com/


For video lectures Youtube – Platinum Classes     Website : www.crackmycbse.com 

 

 

Opening Writer's Table Of Contents Feature 
 

Select Insert > Indexes and Tables > Indexes and Tables. 
 

• Use the Index/Table tab to set the table's attributes. 

• Use the Entries and Styles tabs to format the table entries. 

• Use the Background tab to add color or a graphic to the table 

background.  

 
 

Protecting against manual changes 

To protect the table of contents from being changed accidentally, check the 

Protected against manual changes check box. If this box is checked, the 

table of contents can only be changed using the context menu or the Insert 

Table/Index window 

 

Using the Entries tab 

Use the Entries tab, to format the entries in the table of contents. For 

each outline level, you can add and delete elements, such as chapter 

numbers, and you can also apply character styles to individual elements. 
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Deleting elements 

To delete an element from the Structure line, click the button that represents 

that element and then press the Delete key on your keyboard.  

 

Adding elements 

To add an element to the Structure line, follow these steps: 

1. Place your cursor in the white field to the left of where you want to 

insert the element. 

2. Click one of the five buttons that are just below the Structure line. 

(For example, to add a tab stop, click the Tab stop button.) A button 

representing the new element appears on the Structure line. 

 

Applying character styles 

To apply a character style to an element on the Structure line: 

On the Structure line, click the button that represents the element to which 
you want to apply a style. 
 
From the Character Style drop-down list, select the desired style. Writer 
applies the selected style to the selected element. 
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To apply a paragraph style to an outline level, follow these steps: 

 
1) In the Levels list box, select the desired outline level by clicking it. 
 
2) In the Paragraph Styles list box, click the paragraph style that you want 
to apply. 
 
3) Click the <button to apply the selected paragraph style to the 
selected outline level.  
 
 

SESSION 5: IMPLEMENT MAIL MERGE   

A mail merge is a way to take a letter you’ve written and send it to a whole 
bunch of people, personalizing it with information about them so they might 
think that you typed that letter personally for them. 

 

Create a Mail Merge Document: Letter 
 
1. Open a template, if you have one you want to use, or create a new Writer 
document. 
 
2. Save the document with the appropriate name, like 
mailmerge_openenrollment.ods or mailmerge_parents.odt. 
 
Note: Don’t save it in Word format. You must save it in OpenOffice.org Writer 
format or the mail merge won’t work. 
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Editing a saved file of mailing labels 

To edit a saved file of mailing labels, open the saved label file in the normal 

way. You will be prompted to update all links. Choose No for the following 

reason: The first label on the page is termed the “Master Label” and all other 

labels are linked to it. If you update the links, then all labels will end up 

containing the same data, which is probably not what you want. 

You can edit individual records in the normal way, by highlighting and 

changing the font name, for example. 

 

Preparing for printing 

To prepare mailing labels for printing: 

● Choose File > New > Labels. 

● On the Options tab, ensure that the Synchronize contents option is 

selected. 

● On the Labels tab (), select the Database and Table. Select the Brand 

of labels to be used, and then select the Type of label. 

 

Printing 
● Choose File > Print. The message shown in appears. Click Yes to print. 
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● In the Mail Merge dialog (), you can choose to print all records or selected 

records. To select records to be printed, use Ctrl+click to select individual 

records. To select a block of records, select the first record in the block, 

scroll to the last record in the block, and Shift+click on the last record. 

● Click OK to send the labels directly to the printer. 
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